Tuesday, February 8, 2011

Exchange 2010 / Lync


How did Microsoft manage to make Exchange 2010 such a pig?

Can you tell I'm a little frustrated? I'm trying to with with Exchange 2010 Unified Messaging to test out interoperability with sipXecs/openUC. I've been at this now for well over 2 days worth of time between installing and trying to get systems upgraded.

I'm trying to install Exchange 2010 SP1 at this point and the requirements are killing me. First off, stupid IE won't download anything on the 2008 R2 server so I have chrome installed on that box which works but you can't directly click on the pre-reqs in Microsoft's setup tool. The links don't come up correctly in Chrome. Ok, so I type them all in and get to the last one... Microsoft Speech Server Runtime. The freaking thing won't install because something else is in place. Well, MS in their wisdom upgraded another component that replaced this piece but the server needs this one installed in order to do the upgrade.

What happened to the nice simple days of Exchange 5.5? Man they've gone down hill with this product since then. At least 5.5 was manageable (even if the database puked once in a while, it was easy to fix).

I'm sure Lync will be much better to work with.... gack! No praise coming from this camp.